We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Ip6 - asetukset


simo
09-22-2015, 02:01 PM
Hyvä homma

MikaR
09-21-2015, 06:34 PM
Ja nyt 24 - tunnin testin jälkeen kaikki näyttää toimivan hyvin IPv6 - yhteyden myötä..

root@db:~# ping6 -c 5 2001:41d0:2:321b::1
PING 2001:41d0:2:321b::1(2001:41d0:2:321b::1) 56 data bytes
64 bytes from 2001:41d0:2:321b::1: icmp_seq=1 ttl=64 time=0.349 ms
64 bytes from 2001:41d0:2:321b::1: icmp_seq=2 ttl=64 time=0.233 ms
64 bytes from 2001:41d0:2:321b::1: icmp_seq=3 ttl=64 time=0.279 ms
64 bytes from 2001:41d0:2:321b::1: icmp_seq=4 ttl=64 time=0.156 ms
64 bytes from 2001:41d0:2:321b::1: icmp_seq=5 ttl=64 time=0.250 ms

--- 2001:41d0:2:321b::1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3997ms
rtt min/avg/max/mdev = 0.156/0.253/0.349/0.064 ms
root@db:~# ping6 -c 5 2001:41d0:2:321b::2
PING 2001:41d0:2:321b::2(2001:41d0:2:321b::2) 56 data bytes
64 bytes from 2001:41d0:2:321b::2: icmp_seq=1 ttl=64 time=0.622 ms
64 bytes from 2001:41d0:2:321b::2: icmp_seq=2 ttl=64 time=0.490 ms
64 bytes from 2001:41d0:2:321b::2: icmp_seq=3 ttl=64 time=0.418 ms
64 bytes from 2001:41d0:2:321b::2: icmp_seq=4 ttl=64 time=0.422 ms
64 bytes from 2001:41d0:2:321b::2: icmp_seq=5 ttl=64 time=0.391 ms

--- 2001:41d0:2:321b::2 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3998ms
rtt min/avg/max/mdev = 0.391/0.468/0.622/0.086 ms
root@db:~# ping6 -c 5 2001:41d0:2:321b::3
PING 2001:41d0:2:321b::3(2001:41d0:2:321b::3) 56 data bytes
64 bytes from 2001:41d0:2:321b::3: icmp_seq=1 ttl=64 time=0.218 ms
64 bytes from 2001:41d0:2:321b::3: icmp_seq=2 ttl=64 time=0.333 ms
64 bytes from 2001:41d0:2:321b::3: icmp_seq=3 ttl=64 time=0.322 ms
64 bytes from 2001:41d0:2:321b::3: icmp_seq=4 ttl=64 time=0.266 ms
64 bytes from 2001:41d0:2:321b::3: icmp_seq=5 ttl=64 time=0.329 ms

--- 2001:41d0:2:321b::3 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3998ms
rtt min/avg/max/mdev = 0.218/0.293/0.333/0.048 ms
root@db:~# ping6 -c 5 2001:41d0:2:321b::4
PING 2001:41d0:2:321b::4(2001:41d0:2:321b::4) 56 data bytes
64 bytes from 2001:41d0:2:321b::4: icmp_seq=1 ttl=64 time=0.075 ms
64 bytes from 2001:41d0:2:321b::4: icmp_seq=2 ttl=64 time=0.048 ms
64 bytes from 2001:41d0:2:321b::4: icmp_seq=3 ttl=64 time=0.045 ms
64 bytes from 2001:41d0:2:321b::4: icmp_seq=4 ttl=64 time=0.051 ms
64 bytes from 2001:41d0:2:321b::4: icmp_seq=5 ttl=64 time=0.057 ms

--- 2001:41d0:2:321b::4 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3997ms
rtt min/avg/max/mdev = 0.045/0.055/0.075/0.011 ms

MikaR
09-18-2015, 07:57 PM
Quote Originally Posted by MikaR
Kertoillaan jos jotain ongelmia tulee tähän viestiketjun jatkoksi..


Kaikki muut on oikein mutta tuo kohta jota jäin pähkäilemään on tuo address 2001:41d0:2:3200::/56 kanssa eli alla olevien kaavioiden mukaan mennää nyt sitten.

Esimerkiksi

KVM 1 address 2001:41d0:2:321b::1 <-- Proxmox
KVM 2 address 2001:41d0:2:321b::2
KVM 3 address 2001:41d0:2:321b::3

Proxmoxin /etc/network/interfaces - asetuksiin seuraavanlainen pätkä.


iface vmbr0 inet6 static
address 2001:41d0:2:321b::1
netmask 64

post-up /sbin/ip -f inet6 route add 2001:41d0:2:32ff:ff:ff:ff:ff dev vmbr0
post-up /sbin/ip -f inet6 route add default via 2001:41d0:2:32ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:2:32ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41d0:2:32ff:ff:ff:ff:ff dev vmbr0
Seuraavaksi se KVM 1 - masiina johon halutaan Ip6 - käyttöön /etc/network/interfaces - asetuksiin.

iface eth0 inet6 static
address 2001:41d0:2:321b::1
netmask 64

post-up /sbin/ip -f inet6 route add 2001:41d0:2:32ff:ff:ff:ff:ff dev eth0
post-up /sbin/ip -f inet6 route add default via 2001:41d0:2:32ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41d0:2:32ff:ff:ff:ff:ff dev eth0
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:2:32ff:ff:ff:ff:ff

Myös suotavaa laittaa /etc/sysctl.conf tiedostoon seuraavanlainen pätkä koodia ettei KVM - tunnistele automaattisesti Ip6 - asetuksia proxmoxin kautta.

net.ipv6.conf.eth0.autoconf=0
net.ipv6.conf.eth0.accept_ra=0
Tässä esimerkiksi Ip6 on 2001:41d0:2:321b::/64 joka löytyy So you Startin - hallista kohdasta Ip:t.

ja tätä route -A inet6 add default gw 2001:41d0:2:32ff:ff:ff:ff:ff dev eth0 <-- välttämättä tarvitse koska se tulee nähtävästi automaattisesti.

ja komennolla route -A inet6 selville mitä reititys näyttää


route -A inet6
Kernel IPv6 routing table
Destination Next Hop Flag Met Ref Use If
2001:41d0:2:321b::/64 :: U 256 0 0 eth0
2001:41d0:2:32ff:ff:ff:ff:ff/128 :: U 1024 0 1 eth0
fe80::/64 :: U 256 0 0 eth0
::/0 2001:41d0:2:32ff:ff:ff:ff:ff UG 1024 0 0 eth0
::/0 :: !n -1 1 111 lo
::1/128 :: Un 0 1 27 lo
2001:41d0:2:321b::2/128 :: Un 0 1 93 lo
fe80::ff:fed8:4fe6/128 :: Un 0 1 13 lo
ff00::/8 :: U 256 1 0 eth0
::/0 :: !n -1 1 111 lo

Debian 8 uusin versiossa on sitten jotain aivan eri conffia johon olen yrittänyt saada järkeä.. Näin lopuksi sanon että KVM - ympäristössä toimii parhaiten Ubuntu..
Lopuksi todeten että Proxmox on todella simppeli kun sen siulun elämään pääsee kiinni..

MikaR
09-18-2015, 05:44 PM
Quote Originally Posted by simo
Jes, hyvä että toimii! Voit raportoida vaikka tähän viestiketjuun mikäli ongelmia sattuisi esiintymään IPv6-liikenteen suhteen.
Kertoillaan jos jotain ongelmia tulee tähän viestiketjun jatkoksi..

simo
09-18-2015, 04:59 PM
Jes, hyvä että toimii! Voit raportoida vaikka tähän viestiketjuun mikäli ongelmia sattuisi esiintymään IPv6-liikenteen suhteen.

MikaR
09-18-2015, 03:44 PM
Quote Originally Posted by simo
Ok, mitä ifconfig, ”route -A inet6”, ja ”cat /etc/network/interfaces” kertovat?

Huomasithan että 2001:41d0:2:7c21:xxx oli vain esimerkkiosoite?
route -A inet6 kertoo seuravaa

route -A inet6
Kernel IPv6 routing table
Destination Next Hop Flag Met Ref Use If
2001:41d0:2:3200::/56 :: UAe 256 0 0 eth0
fe80::/64 :: U 256 0 0 eth0
::/0 fe80::222:91ff:fe08:400 UGDAe 1024 1 0 eth0
::/0 fe80::222:91ff:fe08:1c00 UGDAe 1024 0 0 eth0
::/0 :: !n -1 1 107 lo
::1/128 :: Un 0 1 61 lo
fe80::ff:fe5f:b6f6/128 :: Un 0 1 100 lo
ff00::/8 :: U 256 2 0 eth0
::/0 :: !n -1 1 107 lo
cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static
address 37.59.92.33
netmask 255.255.255.255
network 37.59.92.33
broadcast 37.59.92.33
gateway 94.23.49.254
pointopoint 94.23.49.254
dns-nameservers 127.0.0.1 213.186.33.99 8.8.8.8 8.8.4.4
dns-domain ovh.net

iface eth0 inet6 static
address 2001:41d0:2:321b:xxx
netmask 64

post-up /sbin/ip -f inet6 route add 2001:41d0:2:32ff:ff:ff:ff:ff dev eth0
post-up /sbin/ip -f inet6 route add default via 2001:41d0:2:32ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41d0:2:32ff:ff:ff:ff:ff dev eth0
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:2:32ff:ff:ff:ff:ff
Juu nyt toiminee eli tuo address 2001:41d0:2:3200::/56 oli nähtävästi oikea tähän...

simo
09-18-2015, 03:40 PM
Ok, mitä ifconfig, ”route -A inet6”, ja ”cat /etc/network/interfaces” kertovat?

Huomasithan että 2001:41d0:2:7c21:xxx oli vain esimerkkiosoite?

MikaR
09-18-2015, 03:25 PM
Quote Originally Posted by simo
IPv6-yhteys pitäisi tällaisella konfiguraatiolla lähteä toimintaan:



Jossa alimmaisten rivien yhdyskäytäväosoite riippuu oman palvelimesi osoiteavaruudesta. Sinulla yhdyskäytävä on 2001:41d0:2:32ff:ff:ff:ff:ff.

Muista lisäksi lisätä staattinen reitti:



Ja lopuksi uudelleenkäynnistys virtuaalikoneelle:
No ainakin ping6 - toiminee mutta nyt se pukkaa tuollaista tekstiä..


ping6 -c 4 2001:4860:4860::8888
PING 2001:4860:4860::8888(2001:4860:4860::8888) 56 data bytes
From fe80::222:91ff:fe08:1c00 icmp_seq=1 Destination unreachable: Beyond scope of source address
From fe80::222:91ff:fe08:1c00 icmp_seq=2 Destination unreachable: Beyond scope of source address
From fe80::222:91ff:fe08:1c00 icmp_seq=3 Destination unreachable: Beyond scope of source address
From fe80::222:91ff:fe08:1c00 icmp_seq=4 Destination unreachable: Beyond scope of source address

--- 2001:4860:4860::8888 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3011m

simo
09-18-2015, 03:11 PM
IPv6-yhteys pitäisi tällaisella konfiguraatiolla lähteä toimintaan:

root@xyz:~# cat /etc/network/interfaces |tail -n 8
iface eth0 inet6 static
address 2001:41d0:2:7c21:xxx
netmask 64

post-up /sbin/ip -f inet6 route add 2001:41d0:2:7cff:ff:ff:ff:ff dev eth0
post-up /sbin/ip -f inet6 route add default via 2001:41d0:2:7cff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41d0:2:7cff:ff:ff:ff:ff dev eth0
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:2:7cff:ff:ff:ff:ff
Jossa alimmaisten rivien yhdyskäytäväosoite riippuu oman palvelimesi osoiteavaruudesta. Sinulla yhdyskäytävä on 2001:41d0:2:32ff:ff:ff:ff:ff.

Muista lisäksi lisätä staattinen reitti:

route -A inet6 add default gw 2001:41d0:2:7cff:ff:ff:ff:ff dev eth0
Ja lopuksi uudelleenkäynnistys virtuaalikoneelle:

shutdown -r

MikaR
09-18-2015, 02:44 PM
Virtuaali kone otettu käyttöön KVM-tekniikalla..

simo
09-18-2015, 02:34 PM
Hei,

onko virtuaalikone otettu käyttöön OpenVZ- vai KVM-tekniikalla?

MikaR
09-18-2015, 10:45 AM
Hei!
Olen tässä hieman aikaa yrittänyt saada Ip6 - asetuksia toimimaan ja mutta en saa millään hahmotettua sitä että mitä pitää tehdä että saisin virtuaali - palvelimessa joka on Ubuntu niin nuo Ip6:t toimimaan. Eli pää purkki käyttää Proxmox - virtualisointi ja Ubuntu on luotu virtuaalisena.

Tuota olen katsellut http://ohjeet.ovh-hosting.fi/Ipv4Ipv6